Laravel ติดตั้ง packeges ไม่ผ่าน แจ้ง extension ext-zip *

error เต็มๆก็แบบนี้ เกิดขึ้นตอนพยายามติดตั้ง Laravel Dush

Problem 1
– Root composer.json requires PHP extension ext-zip * but it is missing from your system. Install or enable PHP’s zip extension.
Problem 2
– laravel/dusk[v6.15.0, …, 6.x-dev] require ext-zip * -> it is missing from your system. Install or enable PHP’s zip extension.
– Root composer.json requires laravel/dusk ^6.15 -> satisfiable by laravel/dusk[v6.15.0,

วิธีแก้

install brew ด้วย หากติดตั้งแล้วผ่านข้อนี้ไปเบย

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

รันคำสั่งนี้

brew install php@7.3

ตามด้วยคำสั่งนี้

brew link php@7.3 --force

หลังจากนั่นลอง ทดสองติดตั้ง packges ของ laravel อีกครั้ง

ที่มา

https://medium.com/ayuth/%E0%B8%A1%E0%B8%B2%E0%B9%83%E0%B8%8A%E0%B9%89-homebrew-%E0%B9%80%E0%B8%9E%E0%B8%B7%E0%B9%88%E0%B8%AD%E0%B8%8A%E0%B8%B5%E0%B8%A7%E0%B8%B4%E0%B8%95%E0%B8%97%E0%B8%B5%E0%B9%88%E0%B8%94%E0%B8%B5%E0%B8%82%E0%B8%B6%E0%B9%89%E0%B8%99%E0%B8%82%E0%B8%AD%E0%B8%87%E0%B8%8A%E0%B8%B2%E0%B8%A7-macos-%E0%B8%81%E0%B8%B1%E0%B8%99%E0%B9%80%E0%B8%96%E0%B8%AD%E0%B8%B0-f269ed561d2d

https://fantashit.com/requires-ext-zip-the-requested-php-extension-zip-is-missing-from-your-system/

Leave a Reply

Your email address will not be published. Required fields are marked *